~ancarda

Trackers

~ancarda/high-test-coverage

Last active 2 months ago

~ancarda/coverage-enforcer

Last active 7 months ago

~ancarda/gemtext-parser

Last active 9 months ago

~ancarda/psr7-string-stream

Last active 1 year, 10 months ago

~ancarda/tls-redirector

Last active 1 year, 11 months ago

~ancarda/picotest

Last active 2 years ago

#4 Add support for PSR-20 2 months ago

Ticket created by ~ancarda on ~ancarda/high-test-coverage

DateTimeImmutableFactory could easily have a now function that calls __invoke with the default arguments: https://www.php-fig.org/psr/psr-20/

#6 PHP 8.1 support 7 months ago

Ticket created by ~ancarda on ~ancarda/coverage-enforcer

Currently, running the tool under PHP 8.1.x will cause the following error message:

PHP Deprecated: Return type of Symfony\Component\Console\Helper\HelperSet::getIterator() should either be compatible with IteratorAggregate::getIterator(): Traversable, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice

This needs to be fixed in symfony/console

#4 Support symfony/console 6.x 10 months ago

Comment by ~ancarda on ~ancarda/coverage-enforcer

REPORTED RESOLVED FIXED

#2 JsonBomb triggers E_DEPRECATED 10 months ago

Comment by ~ancarda on ~ancarda/high-test-coverage

#2 JsonBomb triggers E_DEPRECATED 10 months ago

Comment by ~ancarda on ~ancarda/high-test-coverage

Mark Dain referenced this ticket in commit c2fcd90.

#2 JsonBomb triggers E_DEPRECATED 10 months ago

Comment by ~ancarda on ~ancarda/high-test-coverage

Mark Dain referenced this ticket in commit 3a811bd.

#2 JsonBomb triggers E_DEPRECATED 10 months ago

Comment by ~ancarda on ~ancarda/high-test-coverage

Mark Dain referenced this ticket in commit a3b4d9c.

REPORTED RESOLVED FIXED

#1 RandomBytes class 11 months ago

Comment by ~ancarda on ~ancarda/high-test-coverage

REPORTED RESOLVED FIXED

#5 Exclude tests with gitattributes 11 months ago

Ticket created by ~ancarda on ~ancarda/coverage-enforcer

Tests are being pulled in and PhpStorm is indexing them

#4 Support symfony/console 6.x 11 months ago

Ticket created by ~ancarda on ~ancarda/coverage-enforcer

Currently, coverage enforcer requires symfony/console:^5.2. This should be expanded to symfony/console:^5.2|^6.0 if possible.