~ehmry/genodepkgs#28: 
Bug in Patchelf prevents replacing .dynstr

Genode binaries should be patched to load libraries by absolute refrence, either by a Nix store path or by a content addressed identifier. Patchelf should do this, but there is a bug that creates a new .dystr section containing the library strings but does not put this into a segment to be loaded. This causes ld.lib.so to segfault as it deferences a pointer to the unloaded segment.

https://github.com/NixOS/patchelf/issues/244

Status
REPORTED
Submitter
~ehmry
Assigned to
No-one
Submitted
5 months ago
Updated
4 months ago
Labels
No labels applied.

~ehmry 4 months ago

Register here or Log in to comment, or comment via email.