~martijnbraam/Megapixels#63: 
Crash after multiple subsequent photos

PMOS edge, Megapixels 1.3.0-r0 on SXMO/sway

Happens reliably after taking a few photos in short order.

Assertion failed: has_changed (../src/io_pipeline.c: update_state: 578)
Aborted
Status
REPORTED
Submitter
~murks
Assigned to
No-one
Submitted
9 months ago
Updated
7 months ago
Labels
No labels applied.

~luigi311 8 months ago*

Can confirm on manjaro phosh dev on version 1.3.0

Leon L. Robinson 8 months ago · edit

I've had this on Fedora with Megapixles 1.3.0

This is the output that I captured

MPCamera: VIDIOC_QBUF error 22, Invalid argument Renderdoc not found Found config file at /usr/share/megapixels/config/pine64,pinephone- 1.2.ini Adding camera rear from config Adding camera front from config Found postprocessor script at /usr/share/megapixels/postprocess.sh Initialized OpenGL ES 2.0 TIFF version 20210416 Writing frame to /tmp/megapixels.hzGd2E/0.dng TIFF version 20210416 Writing frame to /tmp/megapixels.hzGd2E/1.dng Making thumbnail TIFF version 20210416 Writing frame to /tmp/megapixels.hzGd2E/2.dng Post process /tmp/megapixels.hzGd2E to /home/pine/Pictures/IMG20211027135927.ext (save-dng 1) MPCamera: VIDIOC_QBUF error 22, Invalid argument MPCamera: VIDIOC_QBUF error 22, Invalid argument megapixels: ../src/io_pipeline.c:578: update_state: Assertion `has_changed' failed.

It was happening after taking only one photo. After this I had to killall -9 megapixels and take another one.

~benjamin-schaaf 7 months ago

Register here or Log in to comment, or comment via email.