~mediagoblin/mediagoblin#27: 
Upgrade to SQLAlchemy 1.4 (for Guix)

MediaGoblin currently uses SQLAlchemy < 1.4, but Guix recently upgraded to 1.4, so to support Guix we either need to re-introduce 1.3 or upgrade MediaGoblin to 1.4.

Debian Sid currently has 1.4 and Debian Testing has 1.3. Since our deployment docs use a virtualenv, that's mostly not an issue though, since the correct version will be fetched from PyPI.

Status
RESOLVED IMPLEMENTED
Submitter
~sturm
Assigned to
No-one
Submitted
2 years ago
Updated
9 months ago
Labels
No labels applied.

~sturm REPORTED IMPLEMENTED 9 months ago

I've just upgraded to SQLAlchemy 1.4. There is an SQLAlchemy 2.0, but it's not yet in use by Debian Bookworm, Ubuntu 22.04 or Guix.

Register here or Log in to comment, or comment via email.