Unifying sxmo menus with "close" and "system"

i really appreciate phartman's patch that puts "close menu" on top of the network menu!

It was needed for me (to the extent that i was removing older wifi networks to shorten the menu..) but now we're in that weird situation:

in "networks", the "close menu" option is on top, while in all others it is at bottom... but for some other menus (config, apps, scripts) it can become the case that the list is too long, same problem etc..

how about that:

  • every sxmo menu (except some exceptions like system menu of course) have "system menu" / "close menu" as their two first entries? It could be done in a generic way?

could also be "close menu" / "system menu" in that order... point be: 1/ these two elements should be in all menu, ideally along with a "back" option, but probably harder to implement 2/ having them at predictable spot would greatly simplify navigation (ie. always on top) 3/ putting them on top would give them equal visibility/accessbility in all cases...

Assigned to
1 year, 3 months ago
1 year, 3 months ago
No labels applied.

~baroque0 1 year, 3 months ago

comment by hazardchem:

maybe have a template that is called at the start and end of a be/dmenu script? that way the wheel doesnt need to invented each time

maybe apart of sxmo_common?

~phartman 1 year, 3 months ago*

I'd be ok with this approach, but I'm not too interested in doing it myself. One idea is to centralize all the menu code in one spot, and have everything access that (e.g., basically make sxmo_appmenu.sh functions a touch more abstract and have everyone call those, e.g., getprogchoices "network" getprogchoices "contextmenu" etc.) We'd also want to rename "getprogchoices" to "generatemenu" or something of the sort.

~phartman 1 year, 3 months ago


You'd then split out sxmo_hook_contextmenu.sh into several littler scripts: sxmo_menu_sys.sh, sxmo_menu_modem.sh, etc., etc. You'd also have to rewrite e.g. bluetooth and networks which cook their own menus and make them call sxmo_appmenu.sh "bluetooth" for instance.

Register here or Log in to comment, or comment via email.