~robjloranger

https://robloranger.ca


#269 EOF Error 10 months ago

Comment by ~robjloranger on ~sircmpwn/aerc2

I am only using SMTP and the error seems random at best.

#295 aerc does not open with mailto link argument 1 year, 28 days ago

Comment by ~robjloranger on ~sircmpwn/aerc2

Awesome

RESOLVED FIXED RESOLVED FIXED

#295 aerc does not open with mailto link argument 1 year, 28 days ago

Comment by ~robjloranger on ~sircmpwn/aerc2

Awesome

REPORTED RESOLVED FIXED

#295 aerc does not open with mailto link argument 1 year, 28 days ago

Comment by ~robjloranger on ~sircmpwn/aerc2

Which is correct. I applied your patch and tested, it works as described.

During that time I found that I was using the wrong kind of mailto link, which was why the to field was being left empty. I recompliled without your patch and tried again to find that even with the correct link schema, aerc did not open without already having an instance running.

So to summarize; Your patch does work as expected, I was also using the wrong schema but it's only the means to the issue not the cause, this issue was closed as not_our_bug which would be misleading as previous to your patch aerc did not open via aerc mailto:... if not already open. Once that patch is merged then this issue is fixed.

#295 aerc does not open with mailto link argument 1 year, 28 days ago

Comment by ~robjloranger on ~sircmpwn/aerc2

No worries

#295 aerc does not open with mailto link argument 1 year, 28 days ago

Comment by ~robjloranger on ~sircmpwn/aerc2

This isn't resolved, the same behavior exists with a correct mailto link. Perhaps the title should be aerc silently exits when opening mailto links when no instance is running?

#295 aerc does not open with mailto link argument 1 year, 28 days ago

Comment by ~robjloranger on ~sircmpwn/aerc2

I want to say yes, but the spec for this schema does not. So my bad.

I have been writing them that way for years though and all my links appeared to open correctly in whatever client I had configured, even on Android browsers. But this would be supporting something extra, not conforming.

#295 aerc does not open with mailto link argument 1 year, 1 month ago

Comment by ~robjloranger on ~sircmpwn/aerc2

interesting though the to field is not populated. but that would be a different issue as it happens with both master and this patch.

#295 aerc does not open with mailto link argument 1 year, 1 month ago

Comment by ~robjloranger on ~sircmpwn/aerc2

just tested and confirmed working for me

#295 aerc does not open with mailto link argument 1 year, 1 month ago

Comment by ~robjloranger on ~sircmpwn/aerc2

Awesome, thank you. I will test it out shortly.