~sschwarzer/ftputil#111: 
Add deprecation warnings on dropping Python 2 support

As explained ​on the mailing list, a future version 4.0 of ftputil will drop support for Python 2.

For the upcoming version 3.4, add deprecation warnings to notify users about the future lack of Python 2 support.

The only direct public interfaces of ftputil are in ftputil.host and ftputil.error, so add a warning on the module level for these modules.

Status
RESOLVED FIXED
Submitter
schwa (unverified)
Assigned to
No-one
Submitted
5 years ago
Updated
5 years ago
Labels
enhancement library

schwa (unverified) 4 years ago · edit

Fixed in 115238e52cac5964287a644826ffb0c770d48520.

This change issues a deprecation warning under Python 2 as soon as ftputil is imported. This also applies to ftputil.error to catch ftputil exceptions, even when not using ftputil.FTPHost.

Register here or Log in to comment, or comment via email.