~steef

Trackers

~steef/snixembed

Last active 4 months ago

#10 snixembed segfaults after a little while 4 months ago

Comment by ~steef on ~steef/snixembed

I'm sorry, I seem to have missed your last message and the pastebin has sadly expired. As Electron is back to working without SNI, you probably do not need snixembed anymore. But if you still do, and it is still crashing, I would like to look into it.

#9 Cannot build on Linux Mint 18.3 Sylvia x86_64 4 months ago

Comment by ~steef on ~steef/snixembed

Like I mentioned in the matrix room, the error seems to indicate that you're missing the vapi files. They are a dependency of the valac package, do you have that installed? (It is mentioned on the Debian website that valac-bin is an internal package that should not be installed directly, so that package alone is not enough to compile the project.)

#5 AppIndicator: async breaks icon changes (was: MEGAsync) 8 months ago

Comment by ~steef on ~steef/snixembed

3357af7d now has the same behaviour as before the async change. Icons work with the latest node version. (the previous one had a bug as above.) Going to mark this as fixed.

Also, the newest node version brings back the old XEmbed icons again, so most likely snixembed won't be needed (at least for a while) Soon (TM)! Unless you rely on chromium tray icons.

REPORTED RESOLVED FIXED

#10 snixembed segfaults after a little while 8 months ago

Comment by ~steef on ~steef/snixembed

Glad it's working better now! It would be great if you could get some info on the crashes if you have the time, but no worries if you don't. I'll try to reproduce the crash by starting snixembed after some tray apps have started.

if it looks good I'll close the issue later this week. Sorry for the hassle. Sound okay? Sounds good! (If I manage to reproduce I'll reopen)

#5 AppIndicator: async breaks icon changes (was: MEGAsync) 8 months ago

Comment by ~steef on ~steef/snixembed

While it does change IconThemePath, it also seems to set it to nonexistent paths sometimes, which doesn't help. So I now have a build that works sometimes. I will do some more debugging, but this may be an external bug.

#10 snixembed segfaults after a little while 8 months ago

Comment by ~steef on ~steef/snixembed

Hello! What version are you on? Version 2.2 fixes a segmentation fault to do with repeated registration (blueman-applet caused this one).

If that is not it, could you try to get a backtrace using gdb? Using VFLAGS=-g make you can build snixembed with debug symbols. The logging output from snixembed itself would also be helpful (it prints to stdout).

#5 AppIndicator: async breaks icon changes (was: MEGAsync) 8 months ago

Comment by ~steef on ~steef/snixembed

Oof, thanks for catching that one! Looks like Ayatana may change the IconThemePath property when a new icon is set. I'm playing with it, hope to get a fix out soon.

Re-opening this to track this new bug.

RESOLVED FIXED REPORTED

#8 quasselclient: failed to register "org.kde.StatusNotifierItem-7940-1" "/StatusNotifierItem" 8 months ago

Comment by ~steef on ~steef/snixembed

Glad you got it to work!

#9 Cannot build on Linux Mint 18.3 Sylvia x86_64 8 months ago

Comment by ~steef on ~steef/snixembed

Hello! Both errors seem to indicate that your vala (and VAPI for libdbusmenu-gtk3) version is too outdated to build this project. Your Mint version looks out of date. Maybe you can build it on the latest Mint release? I've had bug reports from a Debian user, so I suspect it will also compile fine on the latest Mint. If not, please let me know!

#7 Incompatible with Clementine 9 months ago

Comment by ~steef on ~steef/snixembed

... that is not <b>, <i>, or <u>.